Some customers may be experiencing intermittent slowness due to an upstream network provider issue.
Incident Report for IWT
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 10:49 CST
Identified
We've had reports from a few customers of intermittent system slowness. We have investigated our systems and none of our infrastructure is showing slowness. We have worked with these customers to look at the networking between their networks and our systems and it appears like there may be some slowdowns affecting a portion of the Internet. We have been in contact with our upstream network provider and have made them aware of the issue. We are currently awaiting the results of their investigation.

The issue seems to be only affecting customer's whose traffic to our systems routes through the Dallas area.

We will provide updates here as we receive new information.
Posted Oct 27, 2021 - 12:14 CDT
This incident affected: IWT Systems (IWT Sourcing Suite Web Application, IWT Contract Catalog Web Application, IWT Website).