IWT Contract Catalog Upgrades Additional Issues
Incident Report for IWT
Resolved
We have resolved the remaining issues. Thanks again for your patience!
Posted Oct 14, 2020 - 00:40 CDT
Investigating
We are currently investigating some additional issues related to our recent upgrades.
Posted Oct 13, 2020 - 22:56 CDT
This incident affected: IWT Systems (IWT Contract Catalog Web Application).